Help us to help you!

Our aim is to offer you the best service possible, to do this we need to know: (1.) Joomla! version (2.) Server type (3.) Editor version (4.) JCK Manager version and (5.) any error messages you may have. For help in finding errors please - click here…We would also invite you to read our form rules before posting - read more…

Welcome, Guest
Please Login or Register.    Lost Password?
Forum is locked
Can't view images folder in editor Forum is locked
(1 viewing) (1) Guest
This is a list on known issues that will be addressed in the next official version release.
Go to bottomPage: 1234
TOPIC: Can't view images folder in editor
***
#2284
Can't view images folder in editor 3 Years ago Karma: 0
Hi,

I've been through the documentation and tried as many settings as possible in the plugin parameters and still can't get images to work with CKeditor.

When I click on Browse Server to upload a file there are no files to choose and no folders to browse, a screenshot is attached.

I've tried modifying backend parameters but nothing changes, I must be missing something simple?
Kohhal
Fresh Boarder
Posts: 6
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2011/12/15 11:16 By Paul.F.
The topic has been locked.
 
#2314
Re: Can't view images folder in editor 3 Years ago Karma: 0
I have the same problem!
Mirko Fossa
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#2333
Re: Can't view images folder in editor 3 Years ago Karma: 32
Hi All,

This typically happens when the file browsers connector.php file does not have permission to be executable.

Please see:

It results in the < Resource Type > not being set and files are not loaded in due to a 500 internal server error.

What to do
Joomla recommend 755 and 0644 for folders and files respectively with suPHP installed running on PHP & MySQL 5+ which gives us a level playing field to work too however, you may be using a different configuration and therefore may need to use 777 for your files?

The point being is that Joomla like our editor needs the folders and files to be read/ writable and the entry points for the browsers (this being the file which your browsers need execute) such as the connector.php file must be read/write and executable.

I would contact your hosting provider and ask them what the correct permission should be for your server.

To read Joomla!'s reply on this matter please see:-
* community.joomla.org/blogs/leadership/51...users-listen-up.html
* docs.joomla.org/Security_and_Performance...ctory_permissions.3F
* docs.joomla.org/Security_Checklist_2_-_H...erver_configurations

Kindest Regards,


Paul
Paul (Team Member)
Administrator
Posts: 2038
graph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London Birthday: 12/09
Last Edit: 2011/04/03 23:02 By Paul.F.


Kindest regards,

Paul Franklin

If you use JCK Editor, please post a review at the Joomla! Extensions Directory.
The topic has been locked.
 
#2373
Re: Can't view images folder in editor 3 Years ago Karma: 3
Hi - I'm trying to find this connector.php file to check the settings and hopefully solve this problem...

Any idea where I should be looking? I can't see it anywhere!

I'm using Joomla 1.5.22....

Thanks!
Andy
Junior Boarder
Posts: 32
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#2379
Re: Can't view images folder in editor 3 Years ago Karma: 15
Hi Andybon,

Can i ask what version of the editor are you using
Awills (Team Member)
Administrator
Posts: 991
graphgraph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London

Always clear your browser cache(CTRL+SHFT+DEL for FF/IE and Chrome users)
The topic has been locked.
 
#2386
Re: Can't view images folder in editor 3 Years ago Karma: 0
I'm still having problems, using v3.4.5 with Joomla 1.5.22.

I've updated the Joomla permissions to be the same as everywhere else in my Joomla installation, UID for me the user and GID is apache.

I haven't been able to find connector.php either, there are so many subdirectories in this plugin
Kohhal
Fresh Boarder
Posts: 6
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#2391
Re: Can't view images folder in editor 3 Years ago Karma: 15
Please could you install version 3.4.6 of the editor.


Note: It needs to be a fresh install and then you will need to clear your browser cache(IE+ FF user: CTRl+SHFT+DEL)
Awills (Team Member)
Administrator
Posts: 991
graphgraph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London
Last Edit: 2011/04/04 11:11 By awills.

Always clear your browser cache(CTRL+SHFT+DEL for FF/IE and Chrome users)
The topic has been locked.
 
#2399
Re: Can't view images folder in editor 3 Years ago Karma: 0
Updated to 3.4.6, updated the permissions as stated before, same problem.

Do I need to set this connector.php to 777 (sounds very unsecure!)??
Kohhal
Fresh Boarder
Posts: 6
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#2403
Re: Can't view images folder in editor 3 Years ago Karma: 3
Sure - I'm on 3.4.6....
Andy
Junior Boarder
Posts: 32
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#2404
Re: Can't view images folder in editor 3 Years ago Karma: 0
andybon wrote:
Sure - I'm on 3.4.6....

Me too...but images folder is "not set" just with 777 permission
Mirko Fossa
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#2405
Re: Can't view images folder in editor 3 Years ago Karma: 0
I am having the same issue with 2 of my sites... the others are fine, they are on the same server and nothing is different.. I have done the steps above and still nothing. Any ideas.
William Rock
Fresh Boarder
Posts: 13
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
Go to topPage: 1234

Share this post