Help us to help you!

Our aim is to offer you the best service possible, to do this we need to know: (1.) Joomla! version (2.) Server type (3.) Editor version (4.) JCK Manager version and (5.) any error messages you may have. For help in finding errors please - click here…We would also invite you to read our form rules before posting - read more…

Welcome, Guest
Please Login or Register.    Lost Password?

I can't see files in filebrowser
(1 viewing) (1) Guest
Go to bottomPage: 1234
TOPIC: I can't see files in filebrowser
*
#847
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
awills wrote:
Could you try this:

Replace the file jckeditor/plugins/jfilebrowser/core/connector/php/connector.php

with the attached file in the zip package.
This attachment is hidden for guests. Please login or register to see it.


It also don't work for me, I can't see the files. This haven't solved the problem. :(

What else can I do?
traumportal
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#848
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
Thanks (replying to awills #840), I'd be happy to change the PHP error level. I thought I had done that. I guess I need help here. I'm baffled by what I'm observing.
The default settings in Xampp's PHP.INI file are:
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED
display_errors = On
I've changed these to:
error_reporting = E_ERROR
display_errors = Off
[the PHP.INI comments say:
; E_ALL - All errors and warnings (includes E_STRICT as of PHP 6.0.0)
; E_ERROR - fatal run-time errors]
And, of course, the change you made to connect.php sets error_reporting(E_ERROR)

However I am at a loss to understand the results of these changes. Here is what I observe: (note that I'm clearing cache at every step, and stopping and restarting Xampp after any change to php.ini or the jckeditor code).
I. On Windows 7:
1. Back End: Images File Browsing works OK (yay!), but the warnings continue
(There are 4 warnings; here is the first one: Warning: Parameter 1 to plgEditorALLVideosParameters::afterLoad() expected to be a reference, value given in C:\xampp\htdocs\new\libraries\joomla\event\event.php on line 67)
2. Front End: Same problem as always: Images insertion popup has no "Browse Server" button, and the warnings continue as well.
II. On Windows XP/SP3:
1. Back End: Images File Browsing - the warning messages are gone now, but clicking "Browse Server" in the Images popup does not work, and produces the error box "The File Browser is disabled for security reasons...." (I had failed to check the XP side when I posted my encouraging #838 response - that positive report only applied to the Windows 7 system.)
2. Front End: Same problem as always: Images popup has no "Browse Server" button, but now the warnings are gone.
Don Porter
Junior Boarder
Posts: 21
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#857
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
I came across this problem while fixing another, here's how I fixed it:
remove the & (by reference) from the $params variable from the afterLoad function in the following files:
JOOMLA_PATH\plugins\editors\jckeditor\includes\ckeditor\plugins\editor\client.php
JOOMLA_PATH\plugins\editors\jckeditor\includes\ckeditor\plugins\editor\sigparameters.php
JOOMLA_PATH\plugins\editors\jckeditor\includes\ckeditor\plugins\editor\parameters.php
JOOMLA_PATH\plugins\editors\jckeditor\includes\ckeditor\plugins\editor\allvideosparameters.php

Ensure
display_errors = Off
in php.ini
TeaPot
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2010/09/09 17:47 By T.Wii.
The topic has been locked.
 
#858
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
It doesn't work for me either.

File permissions are good :
1. Joomla's index.php file - 644
2. Joomla's configuration.php file - 644
3. Joomla's plugins folder - 775
4. jckeditor plugins folder - 775
5. Folder with the files - 777

I tried the connector.php file too. Doesn't work :

I see the folders when I load the File Manager (for images or files), but when I navigate through folders, I can't see any files and I can't upload either...



Does the folder need to be called "Files" because, at the moment, my "files" folder is named "documents".

Any other idea ?
Maude
Fresh Boarder
Posts: 2
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#863
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 17
Hi T.Wii

Thanks for your investigative work and hotfix. However, there are case where you do want to pass the parameter object by reference rather than by value.

I have attached a patch file for you to try

Regards
This attachment is hidden for guests. Please login or register to see it.
Awills (Team Member)
Administrator
Posts: 1109
graphgraph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London

Always clear your browser cache(CTRL+SHFT+DEL for FF/IE and Chrome users)
The topic has been locked.
 
#865
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
Changed parameters back to by reference, installed patch and it works. This also fixes the original issues I was having with the AllVideos plug-in not removing the path from the file name, and the file browser authentication saying it was disabled when it shouldn't. Thank you..
TeaPot
Fresh Boarder
Posts: 4
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#889
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
Installed the hotfix and connector.php. Nothing showing in the File Manager. No errors

Joomla Version 1.5.15. MacOSX Safari 5.0.2. Joomla is installed in a subdirectory of the root public html folder

1. Joomla's index.php file - 644
2. Joomla's configuration.php file - 644
3. Joomla's plugins folder - 775
4. jckeditor plugins folder - 775
5. Folder with the files - 777

PHP Built on: Linux dilga.instanthosting.com.au 2.6.18-164.11.1.el5xen #1 SMP Wed Jan 20 08:53:10 EST 2010 i686
Database Version: 5.0.90-community-log
Database Collation: latin1_swedish_ci
PHP Version: 5.2.13
Web Server: Apache
Web Server to PHP interface: cgi
Joomla! Version: Joomla! 1.5.15 Stable [ Wojmamni Ama Mamni ] 05-November-2009 04:00 GMT
User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
jeremy mears
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
Last Edit: 2010/09/14 15:46 By jeremymears.
The topic has been locked.
 
#894
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 17
Joomla recommended chmod settings are 755 for folders and 644 for files

Please make sure all your files and folders are set to those settings and try again

Regards
Awills (Team Member)
Administrator
Posts: 1109
graphgraph
User Offline Click here to see the profile of this user
Gender: Male webxsolution.com Location: London

Always clear your browser cache(CTRL+SHFT+DEL for FF/IE and Chrome users)
The topic has been locked.
 
#895
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
tried that. still no dice. This is rather bothersome.
mdiscenzo
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
#898
Re:I can't see files in filebrowser 4 Years, 1 Month ago Karma: 0
I am having the same problem. I have used this editor on several other sites with no issues, but this last install is so frustrating.

Is there not an easier way to do this? I even tried back installing an older version and it won't open as editor at all.
Dottie McLeroy
Fresh Boarder
Posts: 1
graphgraph
User Offline Click here to see the profile of this user
The topic has been locked.
 
Go to topPage: 1234

Share this post